PCdaZERO.it - Guida facile per usare il computer

Acquista o scarica gratis, i libri di "PC da Zero"

EXCEL AVANZATO 2019    >     Creare un modello offerta completo - parte 2



FACILITA LA TUA ATTIVITÀ CON EXCEL - CHIEDIMI AIUTO

Ti serve aiuto per gestire e automatizzare le tue attività con Excel?
Contattami via email o via telefonica: vedi pagina dei contatti.

Sono a disposizione per analizzare e studiare le tue esigenze e proporti un preventivo per la loro realizzazione.

Vedi chi sono!



Dopo aver inserito la prima formula con la funzione CERCA.VERT, vedi lezione precedente, vediamo ora un piccolo trucco per inserire velocemente la stessa funzione sulle altre celle (cap, località, provincia e p.iva), senza far uso della creazione guidata.

INSERIRE LA FUNZIONE CERCA.VERT SULLE ALTRE CELLE

Ecco quindi come procedere in maniera spedita.
1 - Seleziona la cella F11, dove già esiste la funzione CERCA.VERT
2 - dalla barra della formula seleziona tutto il contenuto (porta il puntatore a sinistra del segno uguale, clicca, tieni premuto e trascina a destra)
selezione del contenuto della barra della formula
3 - porta il puntatore sopra la selezione e clicca con il tasto destro
4 - dal menu apparso clicca su "Copia", o premi la combinazione di tasti CTRL+ C
tasto destro, copia
5 - premi il tasto ESC, posto in alto a sinistra, della tastiera (per uscire dalla modalità modifica)
6 - attiva la cella E13 (cap) e premi il tasto CANC, da tastiera (per cacellarne il contenuto)
7 - clicca sulla barra della formula (per attivarla)
8 - clicca con il tasto destro sulla barra della formula
9 - dal menu apparso clicca sul comando "Incolla"
tasto destro, incolla
10 - premi il tasto [INVIO] da tastiera

Ora dovrai modificare la formula.
11 - attiva la cella E13
12 - dalla barra della formula cancella 2 e sostituiscelo con 3
La formula così modificata sarà la seguente:
=CERCA.VERT(F8;elenco;3;FALSO)

N.B.: Ricordati di premere il tasto INVIO dopo aver effettuato la modifica.

Inserendo il numero 3, verrà prelevato il dato che si trova nella 3^ colonna della tabella elenco, ovvero dal campo "cap". Questo è il motivo del perchè si deve sostituire il 2 con il 3.
funzione cerca.vert copiata e modificata
Bene ora passiamo alla modifica della cella F13.
13 - attiva la cella F13 (località) e premi il tasto CANC da tastiera
14 - clicca sulla barra della formula
15 - clicca con il tasto destro sulla barra della formula
16 - dal menu apparso clicca sul comando "Incolla"
17 - premi il tasto [INVIO] da tastiera
18 - riattiva la cella F13
19 dalla barra della formula modifica il 2 con il 4

La formula così modificata sarà la seguente:
=CERCA.VERT(F8;elenco;4;FALSO)

Inserendo il numero 4, verrà prelevato il dato che si trova nella 4^ colonna della tabella elenco, ovvero dal campo "località". Questo è il motivo del perchè si deve sostituire il numero 2 con il numero 4.
formula cerca.vert modificata
Analogamente ripeti le operazioni sulle celle H13 (prov), F15 (p.iva) e F16 (cod.fisc.),
inserendo rispettivamente, le formule,
=CERCA.VERT(F8;elenco;5;FALSO)
=CERCA.VERT(F8;elenco;6;FALSO)
=CERCA.VERT(F8;elenco;7;FALSO)
campo completati da cerca.vert

CAMBIARE IL FORMATO DELLA CELLA

A questo punto, come vedi dalla immagine sopra, sorge un piccolo problema.
Nella cella della partita iva (F15) e nella cella del codice fiscale (F16), invece del risultato, viene visualizzata la formula.
Questo � successo, perchè la celle F15 e F16 sono formattate con il formato "testo".
Baster� quindi modificare il formato delle celle.

Per cambiare il formato,
1 - clicca con il tasto destro sulla cella F15
2 - dal menu contestuale clicca su "formato celle"
tasto destro, formato celle
3 - dalla scheda "Numero" fai doppio clic su "Generale"
scheda numero, generale
… ma non è finita qui !!
4 - clicca sulla barra della formula e premi il tasto [INVIO], per rionfermare la formula immessa.

5 - ripeti l'operazione anche per la cella F16.

Bene … ci siamo!
campi indirizzo automatizzati

VERIFICARE CHE TUTTO FUNZIONI !

Ora che è stato completato l'inserimento della funzione CERCA.VERT in tutte le celle previste, procediamo a verificare se il tutto funziona a dovere.

Modifica la cella F8 (cliente), digitando i nomi del cliente della tabella elenco
1 - Cancella il contenuto della cella F8
2 - digita Verdi e premi [INVIO]
Nelle altre celle verranno visualizzati i dati relativi al cliente "Verdi".
dati indirizzo cliente verdi
Procedi alla verifica degli altri dati digitando il nome di altri clienti.
3 - cancella Verdi, digita Bianchi e premi [INVIO]
4 - cancella Bianchi e digita Striato e premi [INVIO]
5 - cancella Striato e digita Apua e premi [INVIO]
Se tutto funziona, significa che hai fatto un buon lavoro!

Nella prossima lezione vedremo come migliorare questo modello, creando un menu a discesa. Seguimi






Link sponsorizzati