PCdaZERO.it - Guida facile per usare il computer

Acquista o scarica gratis, i libri di "PC da Zero"

EXCEL AVANZATO 2019    >     Costruire un quiz con la funzione SE



FACILITA LA TUA ATTIVITÀ CON EXCEL - CHIEDIMI AIUTO

Ti serve aiuto per gestire e automatizzare le tue attività con Excel?
Contattami via email o via telefonica: vedi pagina dei contatti.

Sono a disposizione per analizzare e studiare le tue esigenze e proporti un preventivo per la loro realizzazione.

Vedi chi sono!



LA FUNZIONE SE

La funzione SE, restituisce un determinato valore se la condizione specificata ha valore VERO, mentre se il valore risulta FALSO, la funzione fornirà un valore alternativo predeterminato.

Se hai seguito la lezione creare un modello fattura excel, hai già avuto modo di vedere la funzione SE all'opera.
Vediamola più in dettaglio, applicandola alla creazione di un piccolo test.

INSERIAMO LE DOMANDE E LE RISPOSTE

1 - Digita nella casella A1 TEST DI GEOGRAFIA.
2 - Digita nella casella A3 Qual è la capitale di …
e poi di seguito,
3 - dalla cella A4 alla cella A8, digita
ITALIA
SPAGNA
GRECIA
INGHILTERRA
FRANCIA

Salta le colonne B e C,
4 - dalla cella D4 alla cella D8, scrivi le relative risposte:
ROMA
MADRID
ATENE
LONDRA
PARIGI

5 - Allarga le colonne a piacere,
clicca qui, se non ricordi come fare.
A questo punto, il foglio si presenterà come da immagine.
creazione del test di geografia

INSERIRE LA FUNZIONE SE

Procediamo ora ad inserire la funzione SE.

1 - Seleziona la cella C4 e digita:
=SE(B4=D4;"esatta";"errata")
applicazione della funzione se
Tradotta in un linguaggio semplice, significa:
Se la cella B4 ha lo stesso valore della cella D4,
allora scrivi nella cella in cui è inserita la formula (C4), la parola/stringa "esatta",
altrimenti scrivi la parola/stringa "errata".

2 - Copia la formula nelle celle in basso.
Usa il sistema del riempimento automatico (trascinamento).
trascina in basso la formula per copiarla

ANALIZZIAMO LA FUNZIONE SE

La funzione SE ha tre argomenti.
Ti ricordo che gli argomenti si trovano all'interno della parentesi e sono divisi dal punto e virgola.

Nel primo argomento viene inserita la condizione (in questo caso B4=D4)
Nel secondo argomento, viene inserito il valore che deve venire visualizzato se la condizione è vera (in questo caso il valore è la stringa di testo "esatta").

NOTA BENE: se come valore inserisci del testo, quest'ultimo lo devi racchiudere tra virgolette.
Per valori numerici, non è necessaRio inserire le virgolette.

Nel terzo argomento viene inserito il valore che deve venire visualizzato se la condizione è falsa (in questo caso il valore è la stringa di testo "errata").

NIDIFICAZIONE DELLA FUNZIONE SE

Come vedi nella cella C4 viene visualizzato "errata", anche se non è stato digitato nulla nella cella B4. E così pure nelle altre celle della colonna D.
Infatti, la funzione considera falsa l'uguaglianza B4=D4;
questo perchè, in B4 non è stato inserito nulla, mentre D4 ha un valore diverso da nulla.

Per ovviare a questo piccolo "inconveniente", devi far uso della nidificazione della funzione SE, ovvero inserire una funzione SE all'interno di un'altra funzione SE.

NOTA: Se ti sembra complicato, puoi sorvolare questo capitoletto sulla nidificazione. L'esito finale non cambierà nella sostanza, e il test geografico funzionerà comunque.

1 - Seleziona la cella C4
2 - clicca all'interno della barra della formula (o premi F2 o fai doppio clic) per entrare in modlaità modifica cella
3 - e porta il cursore a destra del segno uguale (=)
tasto cursore a destra del segno uguale
4 - Digita SE(B4="";"";
5 - porta il cursore alla fine della formula
6 - e digita ) (parentesi chiusa)
7 - conferma premendo il tasto [invio]

La formula finale sarà questa
=SE(B4="";"";SE(B4=D4;"esatta";"errata"))

Tradotta in parole comuni:
se in B4 non viene digitato nulla (B4=""; è vero), allora visualizza nulla (""),
se in B4 viene digitato qualcosa (B4=""; è falso), allora applica la seguente funzione:
SE(B4=D4;"esatta";"errata").

8 - copia la formula nelle celle in basso, usando il sistema del riempimento automatico.
trascina in basso la formula per copiarla

NASCONDERE UNA COLONNA

Ora procediamo a nascondere i risultati sulla colonna D.
Altrimenti che test sarebbe?!

1 - Seleziona con un clic destro la colonna D
2 - dal menu contestuale clicca sulla voce "Nascondi".
nascondere la colonna D

ABBELLISCI E COLLAUDA IL TEST

Personalizza la grafica delle celle e verifica che il test funzioni, inserendo le risposte partendo dalla cella B4.
formattazione della tabella test

SCOPRIRE LA COLONNA

Se devi aggiungere dati al tuo test, dovrai scoprire la colonna nascosta.
1 - Seleziona le colonne C ed E.
scoprire la colonna D
2 - clicca con il tasto destro sopra la selezione
3 - dal menu contestuale clicca sulla voce "Scopri".
scoprire la colonna D con il menu contestuale






Link sponsorizzati