PCdaZERO.it - Guida facile per usare il computer

Acquista o scarica gratis, i libri di "PC da Zero"

EXCEL AVANZATO 2013    >     Anno bisestile e giorno 29 del mese di febbraio



Ti serve aiuto per gestire e automatizzare le tue attività con Excel?
Contattami via email o via telefonica: vedi pagina dei contatti.

L'aiuto può essere supportato mediante dialogo diretto e condivisione dello schermo.
Potrai così vedere il mio schermo mentre opero e viceversa.

Prezzo orario del servizio: euro 30 + iva 22% (minimo ore 1).-
Versamento anticipato. Vedi modalità di pagamento.

Vedi chi sono!



In questo tutorial, che è la continuazione della lezione precedente, vedremo come risolvere il problema della identificazione automatica dell'anno bisestile, che si presenta nel momento in cui si deve compilare il mese di febbraio.
Come è ben noto infatti, il mese di febbraio in un anno bisestile ha 29 giorni anzichè 28.

CREARE IL MESE DI FEBBRAIO

Facendo riferimento al file creato con la lezione precedente e scaricabile cliccando qui,
procedi ora a creare il mese di febbraio.
1 - Seleziona le celle dalla A1 alla H7
2 - copiale premendo la combinazione di tasti [CTRL] +[C]
3 - seleziona la cella A9
4 - e premi [INVIO] da tastiera (oppure, premi i tasti [CTRL] +[V] )
41-copia-mese.jpg - 40,2 KB
6 - cancella il contenuto della cella A10
7 - e digita nella cella A10 la seguente formula =FINE.MESE(A2;0)+1

La creazione automatica del mese di febbraio non è ancora compiuta.
Rimane da automatizzare il calcolo del numero dei giorni.
29 per i mesi bisestili e 28 per i mesi non bisestili

LA FUNZIONE FINE.MESE()

La funzione FINE.MESE() ti permette, di estrarre l'ultimo giorno del mese, partendo da una qualsiasi data.

Il primo argomento indica la data inizale.
Il secondo argomento indica il numero di mesi successivi o precedenti alla data iniziale.
Nel caso in oggetto, come primo argomento si è scelta la cella A2, ovvero la data di gennaio; e come secondo argomento si è scelto 0 (zero) per individuare il giorno di fine mese dello stesso mese di gennaio.
Aggiungendo poi 1 alla funzione, si ottiene il primo giorno del mese successivo, cioè in questo caso il 1° febbraio.

CANCELLARE UNA CONDIZIONE

Il copia incolla, oltre a copiare valori, formule, e formato, copia anche tutte le condizioni della formattazione condizionale.
Si dovrà in questo caso cancellare le condizioni innoppurtune.

A febbraio il giorno 6 non è festivo (a meno che, capiti di domenica).
Procedi quindi a cancellare la condizione che rendeva rosso il giorno 6.

1 - Seleziona dalla cella B10 alla cella H15
2 - da "Formattazione condizionale" clicca su "Gestisci regole"
3 - seleziona la regola da eliminare ("Valore cella =6")
4 - clicca su "Elimina regola" e su OK.

Cancella ora la 5^ e la 6^ riga del mese, ovvero le righe che possono assumere un valore superiore a 28.
Le prime quattro righe non potranno mai assumere un valore superiore a 28!
1 - Seleziona le celle dalla B14 alla H15
2 - premi il tasto CANC, per cancellare tutto il loro contenuto
42-cancella-B14-H15.jpg - 18,7 KB

COME CAPIRE QUANDO L'ANNO È BISESTILE

L'anno è bisestile quando è divisilbile per 4, ad eccezione degli anni secolari che sono bisestili solo se divisibili per 400.
Per ora semplifichiamo e poniamo di voler creare un calendario automatico fino al 2099, escludendo quindi gli anni secolari.

Per questo problema, usiamo la funzione RESTO().
1 - Nella cella B14 digita =RESTO(ANNO($A$13);4)
Se ottieni 0, significa che l'anno è divisibile per 4 (come impostato dal secondo argomento della funzione).
Ovviamente la formula non è finita!

QUANDO E COME FAR APPARIRE IL GIORNO 29 FEBBRAIO

Affinchè la cella riceva il valore 29 devono essere soddisfatte 2 condizioni:
A - la cella precedente deve avere valore 28;
B - l'anno deve essere bisestile.

La funzione E() ti permette di controllare le sudette condizioni.
1 - Nella cella B14 digita =E(H13=28;RESTO(ANNO($A$13);4))
Tale formula dovrà ovviamente, sostituire la precedente, la quale è stata creata solo per farti vedere il passaggio intermedio.

Se la condizione viene soddisfatta il risultato sarà VERO (=0), altrimenti sarà FALSO (diverso da 0).

Se l'anno in corso è il 2016 il risultato è FALSO.
Pertanto devi fare in modo che la cella assuma il valore di quella precedente + 1,
però solo nel caso la precedente assuma un valore inferiore a 28.

Ed ecco la formula completa che devi
1b - inserire nella cella B14: =SE(H13<28;H13+1;SE(E(H13=28;RESTO(ANNO($A$13);4)=0);29;""))

2 - Nella cella C14 digita la formula
=SE(B14<28;B14+1;SE(E(B14=28;RESTO(ANNO($A$13);4)=0);29;""))

3 - trascina mendiante il riempimento automatico la cella C14 fino alla cella H14.
43-trascina.jpg - 52,4 KB

ESCLUDERE GLI ANNI SECOLARI NON DIVISIBILI PER 400

Per ottenere in seguito, un calendario perpetuo, ti rimane di integrare nella formula,
la condizione che, la cella non deve assumere il valore 29 se l'anno secolare non è divisibile per 400.
Suggerimento:
Se la formula =E(RESTO(A1;100)=0;RESTO(A1;400)=0) assume il valore FALSO, l'anno non è bisestile







Link sponsorizzati