PCdaZERO.it - Guida facile per usare il computer

Acquista o scarica gratis, i libri di "PC da Zero"

CALC AVANZATO    >     Creare un calendario dinamico



pcdazero-vol-1-sesta-ed-180.jpg - 15,3 KB È uscita la Nuova edizione interamente a colori di
PC da zero Volume 1.

Acquistala ora a 28 euro comprese le spese di spedizione!

Clicca qui, per riceverla
comodamente a casa tua.


COSTRUIRE UN CALENDARIO DINAMICO

128-calendario-1 (15K) Con LibreOffice CALC è possibile costruire più calendari dinamici in modo tale che inserendo un solo valore, si crea il calendario del mese desiderato.

PERSONALIZZARE IL FORMATO DATA

Inizia a preparare la cella che conterrà l'unico valore da immettere.

1 - Digita nella casella A1 1/1/11 (ovvero la data 1/1/11) e premi INVIO
Formatta la cella A1 in modo da rendere visibile solo il mese e l'anno.
2 - clic destro cu cella A1
3 - dal menu a discesa scegli "Formatta celle"
01-formato-celle (9K)
4 - clic sulla scheda "Numeri" (se necessario)
5 - clic nella casella sottostante "Codice del formato"
6 - cancella il contenuto e digita MMMM AAAA
02-formato-personalizzato (14K)
7 - clic su OK (o INVIO da tastiera)
8 - allarga la colonna A.

Questo tipo di formattazione personalizzata ti permette di decidere quali dati visualizzare:
giorno a due numeri: GG
giorno a tre lettere: GGG
giorno esteso: GGGG
mese a due numeri: MM
mese a tre lettere: MMM
mese esteso: MMMM
anno a due numeri: AA
anno a quattro numeri: AAAA

Formatta la cella A1 con un colore di sfondo e ingrandisci il carattere.
03-cella-A1 (8K)
La cella A1 riceverà l'unico valore che servirà a generare il calendario dinamico.
I valori immessi nella cella A1 dovranno essere pari al primo giorno di qualsiasi mese.

CREARE LA CELLA CONTENENTE IL PRIMO GIORNO DEL MESE

1 - Digita nella cella A3 =A1
Procedi a formattare la cella A3 con il formato solo giorno esteso e mese.

2 - clic destro su cella A3
3 - dal menu a discesa scegli "Formatta celle"
4 - clic sulla scheda "Numeri" (se necessario)
5 - clic nella casella sottostante "Codice del formato"
6 - cancella il contenuto e digita GGGG GG MMM
7 - clic su OK (o INVIO da tastiera)
04-giorno-mese (10K)

CALENDARIO SU SINGOLA COLONNA

Procediamo a creare il calendario sviluppato su un'unica colonna.

1 - Nella cella A4 digita la formula =A3+1 e premi INVIO
2 - formatta la cella come quella precedente (usa lo strumento "copia formato")
4 - seleziona la cella A4 e trascinala con il riempimento automatico fino alla cella A33
5 - evidenzia le casella da A3 ad A4 con uno sfondo colorato..
05-calendario (16K)
Il calendario è stato creato.
Per creare un nuovo calendario, digita ad esempio, 1/2/11 nella cella A1, e così via.

NASCONDERE LE CELLE DEL MESE SUCCESSIVO

Come avrai notato, se il mese non ha 31 giorni, viene inserito anche il giorno del mese successivo (o più giorni nel caso del mese di febbraio).
Vediamo quindi come nascondere le celle se quest'ultime ricadono nel mese successivo.

Fino al giorno 28 puoi lasciare inalterate le formule,
mentre nelle ultime celle (A31, A32 e A33) procedi a modificare nel seguente modo.

1 - Cancella il contenuto delle celle A31, A32 e A33
2 - nella cella A31 digita la formula =SE(MESE(A30+1)=MESE(A1);A30+1;"")
3 - nella cella A32 digita la formula =SE(MESE(A30+2)=MESE(A1);A30+2;"")
4 - nella cella A33 digita la formula =SE(MESE(A30+3)=MESE(A1);A30+3;"")

La formula inserita, estrae con la funzione MESE il valore del mese della data che propone di inserire (A30+1)
e lo confronta con il mese della cella A1: MESE(A1).
Se il valore coincide, viene inserita la formula A30+1,
altrimenti, se falso, non viene inserito nulla ("").

Per approfondimenti della funzione SE vedi la lezione Costruire un quiz con la funzione SE







Link sponsorizzati