PCdaZERO.it - Guida facile per usare il computer

Acquista o scarica gratis, i libri di "PC da Zero"

EXCEL AVANZATO 2013    >     Creare un modello fattura completo - parte 2



Ti serve aiuto per gestire e automatizzare le tue attività con Excel?
Contattami via email o via telefonica: vedi pagina dei contatti.

L'aiuto può essere supportato mediante dialogo diretto e condivisione dello schermo.
Potrai così vedere il mio schermo mentre opero e viceversa.

Prezzo orario del servizio: euro 30 + iva 22% (minimo ore 1).-
Versamento anticipato. Vedi modalità di pagamento.

Vedi chi sono!



Dopo aver inserito la prima formula con la funzione CERCA.VERT, vedi lezione precedente, vediamo ora un piccolo trucco per inserire velocemente la stessa funzione sulle altre celle (cap, località, provincia e p.iva), senza far uso della creazione guidata.

INSERIRE LA FUNZIONE CERCA.VERT SULLE ALTRE CELLE

Ecco come procedere in maniera spedita.
1 - Seleziona la cella F11, dove già esiste la funzione CERCA.VERT
2 - dalla barra della formula seleziona tutto il contenuto (porta il puntatore a destra del segno uguale, clicca, tieni premuto e trascina a destra)
01-selezione-contenuto-barra-formula.jpg - 30,3 KB
3 - porta il puntatore sopra la selezione e clicca con il tasto destro
4 - dal menu apparso clicca su "Copia"
02-copia.jpg - 23,9 KB
5 - premi il tasto ESC, posto in alto a sinistra, della tastiera (per uscire dalla modalità modifica)
6 - attiva la cella E13 (cap) e premi il tasto CANC, da tastiera (per cacellarne il contenuto)
7 - clicca sulla barra della formula (per attivarla)
8 - clicca con il tasto destro sulla barra della formula
9 - dal menu apparso clicca sul comando "Incolla"
03-incolla.jpg - 15,5 KB
10 - premi il tasto [INVIO] da tastiera

Ora dovrai modificare la formula.
11 - attiva la cella E13
12 - dalla barra della formula cancella 2 e sostituiscelo con 3
La formula così modificata sarà la seguente:
=CERCA.VERT(F8;elenco;3;FALSO)

N.B.: Ricordati di premere il tasto INVIO dopo aver effettuato la modifica.

Inserendo il numero 3, verrà prelevato il dato che si trova nella 3^ colonna della tabella elenco, ovvero dal campo "cap". Questo è il motivo del perchè si deve sostituire il 2 con il 3.
04-cerca-vert-copiata.jpg - 25,0 KB
Bene ora passiamo alla modifica della cella F13.
13 - attiva la cella F13 (località) e premi il tasto CANC da tastiera
14 - clicca sulla barra della formula
15 - clicca con il tasto destro sulla barra della formula
16 - dal menu apparso clicca sul comando "Incolla"
17 - premi il tasto [INVIO] da tastiera
18 - riattiva la cella F13
19 dalla barra della formula modifica il 2 con il 4
La formula così modificata sarà la seguente:
=CERCA.VERT(F8;elenco;4;FALSO)

Inserendo il numero 4, verrà prelevato il dato che si trova nella 4^ colonna della tabella elenco, ovvero dal campo "località". Questo è il motivo del perchè si deve sostituire il 2 con il 4.
05-cerca-vert-modificato.jpg - 14,3 KB
Analogamente ripeti le operazioni sulle celle H13 (prov) e F15 (p.iva)
Inserendo rispettivamente, le formule,
=CERCA.VERT(F8;elenco;5;FALSO)
=CERCA.VERT(F8;elenco;6;FALSO)
06-completamento-cerca-vert.jpg - 10,1 KB

CAMBIARE IL FORMATO DELLA CELLA

A questo punto, come vedi dalla immagine sopra, sorge un piccolo problema.
Nella cella della partita iva (F15) invece del risultato, viene visualizzata la formula.
Questo perchè la cella F15 è formattata con il formato "testo".

Per cambiare il formato,
1 - Clicca con il tasto destro sulla cella F15
2 - dal menu contestuale clicca su "formato celle"
07-formato-celle.jpg - 15,9 KB
3 - dalla scheda "Numero" fai doppio clic su "Generale"
08-formato-numero.jpg - 21,7 KB
… ma non è finita qui !!
4 - clicca sulla barra della formula e premi il tasto [INVIO]
Bene … ci siamo !
09-dati-automatizzati.jpg - 25,8 KB

VERIFICARE CHE TUTTO FUNZIONI !

Ora che è stato completato l'inserimento della funzione CERCA.VERT in tutte le celle previste, procediamo a verificare se il tutto funziona a dovere.

Modifica la cella F8 (cliente), digitando i nomi del cliente della tabella elenco
1 - Cancella il contenuto della cella F8
2 - digita Verdi e premi [INVIO]
Nelle altre celle verranno visualizzati i dati relativi al cliente "Verdi".
10-dati-cliente-verdi.jpg - 8,5 KB
Procedi alla verifica degli altri dati digitando il nome di altri clienti.
3 - cancella Verdi, digita Bianchi e premi [INVIO]
4 - cancella Bianchi e digita Striato e premi [INVIO]
5 - cancella Striato e digita Apua e premi [INVIO]
Se tutto funziona, significa che hai fatto un buon lavoro!

USARE LA CONVALIDA PER LIMITARE I DATI IMMESSI

Finora abbiamo dovuto inserire il nome dei clienti digitandoli interamente da tastiera.
Ebbene, se vogliamo rendere più dinamico questo modulo, in modo da poter scegliere i clienti da un menu a tendina, dobbiamo usare lo strumento CONVALIDA DATI.

La convalida di una cella ci permette di limitare i dati da immettere ed eventualmente selezionarli da un elenco a discesa.

Procediamo quindi ad applicare la convalida alla cella desiderata.
1 - Seleziona la cella da convalidare (nel nostro caso F8)
2 - dalla barra multifunzione, clicca sulla scheda DATI
3 - clicca sul comando "Convalida dati"
11-convalida-dati.jpg - 45,6 KB
3 - dal menu a discesa "Consenti" clicca sulla voce Elenco
12-consenti-elenco.jpg - 21,4 KB
4 - nella casella origine digita =clienti (non dimenticarti di digitare = uguale)
Questo è l'intervallo di celle A1:A10, che, se ti ricordi, è stato nominato nella lezione precedente.
13-elenco-clienti.jpg - 18,0 KB
5 - clicca su OK per confermare
Osserva, a fianco della cella F8 vedi il classico triangolino nero.
6 - clicca sul triangolino e dal menu a discesa clicca sul nome del cliente desiderato.
14-menu-clienti.jpg - 10,7 KB
Fantastico, vero!?

TOGLIERE IL COLORE ALLE CELLE

Ora, solamente per una questione visiva e pratica, puoi togliere il colore azzurro sulle celle indirizzo, cap, località, prov e p.iva, per renderle differenti da quelle compilate "a mano".
1 - Seleziona dalla cella E11 alla cella F15
15-seleziona-celle.jpg - 13,3 KB
2 - dalla scheda "HOME"
3 - clicca su colore riempimento (sulla freccetta nera)
4 - clicca su "Nessun riempimento".
16-colore-nessun-riempimento.jpg - 32,4 KB

INSERIRE LA FUNZIONE SE SULLA FUNZIONE CERCA.VERT

C'è un altro piccolo particolare da correggere!
quando non viene inserita la provincia sull'elenco clienti, sulla cella H13 appare uno zero.
Per non visualizzare questo zero, si deve applicare ancora una volta la funzione SE.
1 - Seleziona la cella H13
2 - clicca sulla barra della formula
3 - modifica la formula nel modo seguente
=SE(CERCA.VERT(F8;elenco;5;FALSO)="";"";CERCA.VERT(F8;elenco;5;FALSO))
4 - premi il tasto [INVIO] da tastiera.

INSERIRE LA CONVALIDA E LA FUNZIONE CERCA.VERT SUGLI ARTICOLI

Per esercizio prova ad automatizzare anche gli articoli della fattura. Usa la funzione CERCA.VERT e la CONVALIDA DATI

Suggerimento:
inserisci un altro foglio di lavoro e crea una tabella articoli
17-tabella-articoli.jpg - 27,6 KB
Se non riesci a raggiungere la "meta", puoi scaricare
cliccando qui
il modello fattura completo con la tabella clienti e la tabella articoli.






Link sponsorizzati