PCdaZERO.it - Guida facile per usare il computer

Acquista o scarica gratis, i libri di "PC da Zero"

EXCEL AVANZATO 2013    >     Costruire un quiz con la funzione SE



Ti serve aiuto per gestire e automatizzare le tue attività con Excel?
Contattami via email o via telefonica: vedi pagina dei contatti.

L'aiuto può essere supportato mediante dialogo diretto e condivisione dello schermo.
Potrai così vedere il mio schermo mentre opero e viceversa.

Prezzo orario del servizio: euro 30 + iva 22% (minimo ore 1).-
Versamento anticipato. Vedi modalità di pagamento.

Vedi chi sono!



LA FUNZIONE SE

La funzione SE, restituisce un determinato valore se la condizione specificata ha valore VERO e un altro valore se essa ha valore FALSO.
Se hai seguito la lezione creare un modello fattura excel, hai già avuto modo di vedere la funzione SE all'opera.
Vediamola più in dettaglio, applicandola alla creazione di un piccolo test.

INSERIAMO LE DOMANDE E LE RISPOSTE

1 - Digita nella casella A1 TEST DI GEOGRAFIA.
2 - Digita nella casella A3 Qual è la capitale di …
e poi di seguito,
3 - dalla cella A4 alla cella A8, digita
ITALIA
SPAGNA
GRECIA
INGHILTERRA
FRANCIA
Salta le colonne B e C,
4 - dalla cella D4 alla cella D8, scrivi le relative risposte:
ROMA
MADRID
ATENE
LONDRA
PARIGI
5 - Allarga le colonne a piacere,
clicca qui, se non ricordi come fare.
A questo punto, il foglio si presenterà come da immagine.
01-test-di-geografia.jpg - 17,3 KB

INSERIRE LA FUNZIONE SE

Procediamo ora ad inserire la funzione SE.

1 - Seleziona la cella C4 e digita:
=SE(B4=D4;"esatta";"errata")
02-funzione-se.jpg - 10,8 KB
Tradotta in un linguaggio semplice, significa:
Se la cella B4 ha lo stesso valore della cella D4,
allora scrivi nella cella in cui è inserita la formula (C4), la parola "esatta",
altrimenti scrivi la parola "errata".

2 - Copia la formula nelle celle in basso.
Usa il sistema del riempimento automatico (trascinamento).
03-trascina-formula.jpg - 20,6 KB

ANALIZZIAMO LA FUNZIONE SE

La funzione SE ha tre argomenti (divisi dal punto e virgola).
Nel primo argomento inserisci la condizione (in questo caso B4=D4)
Nel secondo argomento, inserisci il valore che vuoi venga visualizzato se la condizione è vera (in questo caso il valore è la stringa di testo "esatta").

NOTA BENE: se come valore inserisci del testo lo devi racchiudere tra virgolette.
Per valori numerici, non inserire le virgolette.

Nel terzo argomento inserisci il valore che vuoi venga visualizzato se la condizione è falsa (in questo caso il valore è la stringa di testo "errata").

NIDIFICAZIONE DELLA FUNZIONE SE

Come vedi nella cella C4 viene visualizzato "errata", anche se non è stato digitato nulla nella cella B4. E così pure nelle altre celle della colonna D.
Infatti, la funzione considera falso l'uguaglianza B4=D4,
perchè in B4 non c'è scritto nulla, mentre D4 ha un valore diverso da nulla.
Per ovviare a questo piccolo "inconveniente", devi far uso della nidificazione della funzione SE, ovvero inserire una funzione SE all'interno di un'altra funzione SE.

NOTA: Se ti sembra complicato, puoi sorvolare questo capitoletto sulla nidificazione. L'esito finale non cambierà nella sostanza, e il test geografico funzionerà comunque.

1 - Seleziona la cella C4
2 - clicca all'interno della barra della formula (o premi F2 o fai doppio clic)
3 - e porta il cursore a destra dell'uguale (=)
04-cursore-a-destra-di-uguale.jpg - 22,2 KB
4 - Digita SE(B4="";"";
5 - porta il cursore alla fine della formula
6 - e digita ) (parentesi chiusa)
La formula finale sarà questa
=SE(B4="";"";SE(B4=D4;"esatta";"errata"))

Tradotta in parole comuni:
se in B4 non viene digitato nulla (B4=""; è vero), allora visualizza nulla (""),
se in B4 viene digitato qualcosa (B4=""; è falso), allora applica la seguente funzione:
SE(B4=D4;"esatta";"errata").

7 - copia la formula nelle celle in basso, usando il sistema del riempimento automatico.
05-se-nidificato.jpg - 25,8 KB

NASCONDERE UNA COLONNA

Ora procediamo a nascondere i risultati sulla colonna D.
Altrimenti che test sarebbe?!
1 - Seleziona con un clic destro la colonna D
2 - dal menu contestuale clicca sulla voce "Nascondi".
06-nascondi-colonna.jpg - 39,3 KB

ABBELLISCI E COLLAUDA IL TEST

Personalizza la grafica delle celle e verifica che il test funzioni, inserendo le risposte partendo dalla cella B4.
07-risposte-al-test.jpg - 21,1 KB

SCOPRIRE LA COLONNA

Se devi aggiungere dati al tuo test, dovrai scoprire la colonna nascosta.
1 - Seleziona le colonne C ed E.
08-seleziona-2-colonne.jpg - 24,3 KB
2 - clicca con il tasto destro sopra la selezione
3 - dal menu contestuale clicca sulla voce "Scopri".

09-scopri-colonna.jpg - 40,5 KB






Link sponsorizzati